summaryrefslogtreecommitdiff
path: root/lib/librte_power/meson.build
diff options
context:
space:
mode:
authorLiang Ma <liang.j.ma@intel.com>2018-12-20 14:43:42 +0000
committerThomas Monjalon <thomas@monjalon.net>2018-12-21 01:33:59 +0100
commite6c6dc0f96c8b2b353061ae27b1059038189b709 (patch)
treef6dd4e2436f1a0fb1b2840672bad4fa8df7eb74f /lib/librte_power/meson.build
parent85d6815fa6d071afc323c3a0bdfe2d0769ec33d0 (diff)
power: add p-state driver compatibility
Previously, in order to use the power library, it was necessary for the user to disable the intel_pstate driver by adding “intel_pstate=disable” to the kernel command line for the system, which causes the acpi_cpufreq driver to be loaded in its place. This patch adds the ability for the power library use the intel-pstate driver. It adds a new suite of functions behind the current power library API, and will seamlessly set up the user facing API function pointers to the relevant functions depending on whether the system is running with acpi_cpufreq kernel driver, intel_pstate kernel driver or in a guest, using kvm. The library API and ABI is unchanged. Signed-off-by: Liang Ma <liang.j.ma@intel.com> Reviewed-by: Anatoly Burakov <anatoly.burakov@intel.com> Acked-by: David Hunt <david.hunt@intel.com>
Diffstat (limited to 'lib/librte_power/meson.build')
-rw-r--r--lib/librte_power/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/librte_power/meson.build b/lib/librte_power/meson.build
index 9ed8b56da4..02e0337ced 100644
--- a/lib/librte_power/meson.build
+++ b/lib/librte_power/meson.build
@@ -6,6 +6,7 @@ if host_machine.system() != 'linux'
endif
sources = files('rte_power.c', 'power_acpi_cpufreq.c',
'power_kvm_vm.c', 'guest_channel.c',
- 'rte_power_empty_poll.c')
+ 'rte_power_empty_poll.c',
+ 'power_pstate_cpufreq.c')
headers = files('rte_power.h','rte_power_empty_poll.h')
deps += ['timer']