summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-04-17 00:55:34 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-04-17 00:55:34 +0000
commit525689823d7dcd269b052c58545a5ff1d8db65f8 (patch)
tree3802071d97bd6f048446ea4a220f0b11fab174db /Makefile.am
parent4eab875811c415d894626b51818a447adfa1af71 (diff)
Remove warnings about conflicts with the stable version.GLIB_1_3_3
Mon Apr 16 12:04:52 2001 Owen Taylor <otaylor@redhat.com> * configure.in: Remove warnings about conflicts with the stable version. * glib-2.0.m4: Fix some of the error text to be halfway up to date. * README.in INSTALL.in: Add these to generate README, INSTAL (as in the stable branch). Update. * HACKING: Update.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c62d7ea7..ae51ab046 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,7 +30,7 @@ EXTRA_DIST = \
gen-unicode-tables.pl
# These may be in the builddir too
-BUILT_EXTRA_DIST = \
+BUILT_EXTRA_DIST = \
makefile.msc \
makefile.mingw \
glibconfig.h.win32 \
@@ -235,7 +235,8 @@ snapcheck:
$(MAKE) distcheck distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
dist-hook: $(BUILT_EXTRA_DIST)
- files='$(BUILT_EXTRA_DIST)'; \
+ cd $(top_builddir) && CONFIG_FILES="INSTALL README" CONFIG_HEADERS= $(SHELL) ./config.status
+ files='$(BUILT_EXTRA_DIST)' INSTALL README; \
for f in $$files; do \
if test -f $$f; then d=.; else d=$(srcdir); fi; \
- cp $$d/$$f $(distdir) || exit 1; done
+ rm -f $(distdir)/$$f && cp $$d/$$f $(distdir) || exit 1; done