summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2010-05-13 23:08:34 -0400
committerMatthias Clasen <mclasen@redhat.com>2010-05-13 23:08:34 -0400
commit6223341cacc7dfa34a8d60ec1b4828382dee6d07 (patch)
tree9969de8c5b3c6fb2307f197a47a9ff4f6a48a728 /configure.in
parenta7c4c7de58a48c179e4dc3336814f63c33ad07ff (diff)
parent6e8637e4783ae4e573f6784f005920930d9fca87 (diff)
Merge branch 'gdbus-merge'
Conflicts: docs/reference/gio/gio-docs.xml docs/reference/gio/gio-sections.txt gio/tests/Makefile.am
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 62a21391a..91d6f258b 100644
--- a/configure.in
+++ b/configure.in
@@ -3496,6 +3496,16 @@ if test x$glib_win32_static_compilation = xyes; then
fi
])
+# Check for libdbus1 - Optional - is only used in the GDBus test cases
+#
+PKG_CHECK_MODULES(DBUS1,
+ dbus-1,
+ [AC_DEFINE(HAVE_DBUS1, 1, [Define if dbus-1 is available]) have_dbus1=yes],
+ have_dbus1=no)
+AC_SUBST(DBUS1_CFLAGS)
+AC_SUBST(DBUS1_LIBS)
+AM_CONDITIONAL(HAVE_DBUS1, [test "x$have_dbus1" = "xyes"])
+
AC_CONFIG_FILES([
glib-2.0.pc
glib-2.0-uninstalled.pc