summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-01-12 21:28:23 +0100
committerAlexander Larsson <alexl@redhat.com>2010-01-12 21:37:50 +0100
commit94b8613b5ffefadb5c82424bd1f3083ff11fa811 (patch)
treefd14d8981fed01e7bfe77e8e0a8ec8fe8efeef51 /configure.in
parentde5c708e0b3d257388d3a5d09c80806d27069c88 (diff)
Use unconditional thread calls in gio and gobject
If threads are available we always enable threads in gobject, which means all gio/gobject code can enable the unconditional thread calls. This is a minor optimization since we avoid a bunch of unnecessary is-threads-enabled checks. https://bugzilla.gnome.org/show_bug.cgi?id=606775
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8221911f8..bc4310254 100644
--- a/configure.in
+++ b/configure.in
@@ -2349,6 +2349,7 @@ case $host in
;;
esac
+AM_CONDITIONAL(HAVE_THREADS, [test "$have_threads" != "none"])
AC_DEFINE_UNQUOTED(G_THREAD_SOURCE,"gthread-$have_threads.c",
[Source file containing theread implementation])
AC_SUBST(G_THREAD_CFLAGS)