summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2024-02-02 14:33:22 +0000
committerPhilip Withnall <philip@tecnocode.co.uk>2024-02-02 14:33:22 +0000
commit3f4e6ddcd88d4014401f8c0061b86fc0f39fac13 (patch)
treee29a267500efa60177df90c2def078b180462648 /meson.build
parent35f42d0c8ccc36f8eb9bc26d63e3f2f8e86f8555 (diff)
parent16b93f92fa5f7ef39f8a40a34993e6d101bfbb38 (diff)
Merge branch 'thorough-tests-in-ci' into 'main'
build: Add thorough test setup See merge request GNOME/glib!3838
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bf05d5fa6..c14b7f5f1 100644
--- a/meson.build
+++ b/meson.build
@@ -193,6 +193,13 @@ add_test_setup('unstable_tests',
#suites: ['flaky', 'unstable']
)
+add_test_setup('thorough',
+ exclude_suites: ['flaky', 'failing', 'performance'],
+ env: common_test_env,
+ timeout_multiplier: 20,
+ exe_wrapper: [find_program('./.gitlab-ci/thorough-test-wrapper.sh', required: true)],
+)
+
# Allow the tests to be easily run under valgrind using --setup=valgrind
valgrind = find_program('valgrind', required: false)
valgrind_suppression_file = files('tools' / 'glib.supp')[0]