summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKleis Auke Wolthuizen <github@kleisauke.nl>2024-02-21 12:38:40 +0100
committerKleis Auke Wolthuizen <github@kleisauke.nl>2024-02-21 12:38:40 +0100
commit72d76922dc7b29913220169d76e84b1f28b5301a (patch)
tree9383891e21835afe335b059e972a6cb29ea2bf43 /meson.build
parent241df32d7abdcffdcfbfba9fb8715e2530443009 (diff)
girepository: Fix static build under Windows
Properly define `GI_STATIC_COMPILATION` when static build is enabled. Use `library()` instead of `shared_library()` to allow selecting static builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cee1cab9d..130715aca 100644
--- a/meson.build
+++ b/meson.build
@@ -316,6 +316,7 @@ if glib_build_static_only
glibconfig_conf.set('GOBJECT_STATIC_COMPILATION', '1')
glibconfig_conf.set('GIO_STATIC_COMPILATION', '1')
glibconfig_conf.set('GMODULE_STATIC_COMPILATION', '1')
+ glibconfig_conf.set('GI_STATIC_COMPILATION', '1')
glibconfig_conf.set('G_INTL_STATIC_COMPILATION', '1')
glibconfig_conf.set('FFI_STATIC_BUILD', '1')
endif