summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMarco Barisione <marco@barisione.org>2007-03-15 13:01:31 +0000
committerMarco Barisione <mbari@src.gnome.org>2007-03-15 13:01:31 +0000
commit0196d639753247cb0d8aca289155154ef6daa561 (patch)
tree65e59b7d88c9c2609c92512fe301cf783c21d4df /tests/Makefile.am
parentaf8671792d05d52df78ea3a26e182fffe7b37a94 (diff)
Add GRegex for regular expression matching. (#50075)
2007-03-15 Marco Barisione <marco@barisione.org> Add GRegex for regular expression matching. (#50075) * configure.in: Handle GRegex compilation. * glib/gregex.c: * glib/gregex.h: Code for GRegex. * glib/Makefile.am: * glib/makefile.msc.in: Updated makefiles. * glib/pcre/*: Internal copy of PCRE. * glib/update-pcre/*: Stuff to automatically update the internal PCRE to a newer version. * tests/regex-test.c: * tests/Makefile.am: * tests/makefile.msc.in: Add tests for GRegex. svn path=/trunk/; revision=5408
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2964bd1f5..f4ab9b398 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,12 @@
SUBDIRS=gobject refcount
-INCLUDES = -g -I$(top_srcdir) -I$(top_srcdir)/glib -I$(top_srcdir)/gmodule $(GLIB_DEBUG_FLAGS)
+if ENABLE_REGEX
+enable_regex = -DENABLE_REGEX
+else
+enable_regex =
+endif
+
+INCLUDES = -g -I$(top_srcdir) -I$(top_srcdir)/glib -I$(top_srcdir)/gmodule $(GLIB_DEBUG_FLAGS) $(enable_regex)
EFENCE=
@@ -112,7 +118,8 @@ test_programs = \
unicode-encoding \
utf8-validate \
utf8-pointer \
- uri-test
+ uri-test \
+ regex-test
test_scripts = run-markup-tests.sh run-collate-tests.sh run-bookmark-test.sh
@@ -183,6 +190,7 @@ unicode_collate_LDADD = $(progs_ldadd)
utf8_validate_LDADD = $(progs_ldadd)
utf8_pointer_LDADD = $(progs_ldadd)
uri_test_LDADD = $(progs_ldadd)
+regex_test_LDADD = $(progs_ldadd)
lib_LTLIBRARIES = libmoduletestplugin_a.la libmoduletestplugin_b.la