summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2006-12-18 14:50:36 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2006-12-18 14:50:36 +0000
commit330e9ffc1b0e47f1aee8ae3b0b25844166516fc6 (patch)
tree051bf39d2f9d41b6d3d0851af04268b45d9bae0d /tests/Makefile.am
parent558383d62c8c63027e0f192b02a0fdd86690351e (diff)
Try a different fix for bug 346373.
2006-12-18 Matthias Clasen <mclasen@redhat.com> * tests/Makefile.am: Try a different fix for bug 346373.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index affb6b10f..601d95838 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -121,7 +121,7 @@ TESTS = $(test_programs) $(test_scripts)
TESTS_ENVIRONMENT = srcdir=$(srcdir) \
LIBCHARSET_ALIAS_DIR=$(top_builddir)/glib/libcharset \
MALLOC_CHECK_=2 \
- if test "$$RANDOM" != "" ; then MALLOC_PERTURB_=$$(($$RANDOM % 256)); fi
+ MALLOC_PERTURB_=$$(($${RANDOM:-256} % 256))
progs_ldadd = $(EFENCE) $(libglib) $(EFENCE)
thread_ldadd = $(libgthread) $(G_THREAD_LIBS) $(progs_ldadd)