summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
author09:27:42 Tim Janik <timj@imendio.com>2007-12-06 08:32:03 +0000
committerTim Janik <timj@src.gnome.org>2007-12-06 08:32:03 +0000
commit871897db961d7228da6b844eaa0b6f6636771c24 (patch)
treec0dfa31e3ff9702a5150ef0247ed46aef184dd3f /tests/Makefile.am
parent66f1845caaf91954d85d7b1d8e44c892e11ffb73 (diff)
added new scanner test from #501654, by Patrick Hulin with various
2007-12-06 09:27:42 Tim Janik <timj@imendio.com> * tests/scannerapi.c: added new scanner test from #501654, by Patrick Hulin with various modifications. reworked coding style, adapted to new testing framework, fixed token parser test and use a forked sub process to test g_scanner_error() output messages. svn path=/trunk/; revision=6055
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 11da3ad33..7454e6a0f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -65,7 +65,7 @@ endif
if ENABLE_TIMELOOP
timeloop = timeloop timeloop-closure
endif
-noinst_PROGRAMS = \
+noinst_PROGRAMS = $(TEST_PROGS) \
testglib \
testgdate \
testgdateparser \
@@ -74,6 +74,11 @@ noinst_PROGRAMS = \
$(timeloop) \
errorcheck-mutex-test
+TEST_PROGS += scannerapi
+scannerapi_SOURCES = scannerapi.c
+scannerapi_LDADD = $(progs_ldadd)
+
+
testglib_LDADD = $(libglib)
patterntest_LDADD = $(libglib)
testgdate_LDADD = $(libglib)