summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2018-09-23 13:44:15 -0400
committerXavier Claessens <xavier.claessens@collabora.com>2018-10-10 13:51:06 -0400
commitac7534fe10631307f04bbc0dfbeefcc7e7b96936 (patch)
tree4a0499c006d29f1f10cf026e311a03fa30da52f6 /tests/meson.build
parentaa02dac84f52ab0dea09163b262f5ef35e3dd01f (diff)
Meson: Run in TAP mode installed tests that support it
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index b054a1732..87110fd47 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -18,7 +18,7 @@ subdir('refcount')
# FIXME: We are using list of dictionnaries until we can depend on Meson 0.48.0
# that supports '+=' operator on dictionnaries.
tests = [{
- 'testglib' : {},
+ 'testglib' : {'tap' : true},
'testgdate' : {},
'datetime' : {},
'atomic-test' : {},
@@ -101,13 +101,14 @@ foreach test_dict : tests
source = extra_args.get('source', test_name + '.c')
extra_sources = extra_args.get('extra_sources', [])
install = installed_tests_enabled and extra_args.get('install', true)
+ template = extra_args.get('tap', false) ? installed_tests_template_tap : installed_tests_template
if install
test_conf = configuration_data()
test_conf.set('installed_tests_dir', installed_tests_execdir)
test_conf.set('program', test_name)
configure_file(
- input: installed_tests_template,
+ input: template,
output: test_name + '.test',
install_dir: installed_tests_metadir,
configuration: test_conf