summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 378bcb3a7..a69f1dd25 100644
--- a/configure.in
+++ b/configure.in
@@ -215,6 +215,17 @@ else
AC_MSG_RESULT([yes])
fi
+if test "$glib_native_win32" = "yes"; then
+ if test x$enable_static = xyes -o x$enable_static = x; then
+ AC_MSG_WARN([Disabling static library build, must build as DLL on Windows.])
+ enable_static=no
+ fi
+ if test x$enable_shared = xno; then
+ AC_MSG_WARN([Enabling shared library build, must build as DLL on Windows.])
+ fi
+ enable_shared=yes
+fi
+
dnl Checks for programs.
AC_PROG_CC
@@ -410,7 +421,6 @@ esac
dnl Initialize libtool
AM_DISABLE_STATIC
-AC_LIBTOOL_WIN32_DLL
AM_PROG_LIBTOOL
if test "x$GCC" = "xyes"; then
@@ -1466,6 +1476,10 @@ if test x"$have_threads" != xno; then
G_THREAD_CFLAGS="-Kthread"
G_THREAD_LIBS=$G_THREAD_CFLAGS
;;
+ *-mingw*)
+ # No flag needed when using MSVCRT.DLL
+ G_THREAD_CFLAGS=""
+ ;;
*)
G_THREAD_CFLAGS="-D_REENTRANT" # good default guess otherwise
;;