summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6084471f8..d788cdfe1 100644
--- a/meson.build
+++ b/meson.build
@@ -2456,8 +2456,22 @@ if want_systemtap and enable_dtrace
enable_systemtap = true
endif
+# introspection
+gir_scanner = find_program('g-ir-scanner', required: get_option('introspection'))
+enable_gir = get_option('introspection').allowed() and gir_scanner.found() and meson.can_run_host_binaries()
+
+if get_option('introspection').enabled() and not meson.can_run_host_binaries()
+ error('Running binaries on the build host needs to be supported to build with -Dintrospection=enabled')
+endif
+
+gir_args = [
+ '--quiet',
+]
+
pkg = import('pkgconfig')
windows = import('windows')
+gnome = import('gnome')
+
subdir('tools')
subdir('glib')
subdir('gobject')
@@ -2579,4 +2593,5 @@ summary({
'glib_checks' : get_option('glib_checks'),
'libelf' : get_option('libelf'),
'multiarch' : get_option('multiarch'),
+ 'introspection' : enable_gir,
}, section: 'Options')