summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2009-10-14 08:50:31 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-10-14 08:50:31 +0200
commit1b569d8cb42b6bbcfad261166c7b009e61587ad3 (patch)
treedcef0a02cae1a9895c14c2feaaf8bfbe765658f7 /Makefile.am
parentb8454d623d4d92949a0548b8d1d6bc061e18b11b (diff)
build: Only run make check-exports if no public API was disabled
Fixes bug #598297.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d6ebb71d3..13ce24305d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -140,5 +140,14 @@ check-enum-gettypes: $(top_builddir)/gst/gstenumtypes.h
include $(top_srcdir)/common/coverage/lcov.mak
-check: check-exports check-enum-gettypes
+# Do not run the check-exports test in case any option which causes the API to
+# change has been used
+if !GST_DISABLE_LOADSAVE
+if !GST_DISABLE_REGISTRY
+if !GST_DISABLE_TRACE
+CHECK_EXPORTS = check-exports
+endif
+endif
+endif
+check: $(CHECK_EXPORTS) check-enum-gettypes