summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2014-10-26 14:55:49 +0000
committerTim-Philipp Müller <tim@centricular.com>2014-10-26 15:01:01 +0000
commit52e4bbab9ecb9e9796ad29369380ddd6ddefdeb1 (patch)
tree60f149d263564cab60d96d7b7c428780321879e6 /Makefile.am
parent4aac09e7088ded56950c8f281b327b904c41a184 (diff)
Parallelise 'make check-valgrind'
Some of the RTP unit tests are very flaky and will fail more often with the CPU maxed out fully. Those tests need to be fixed in any case though, they also fail on slower machines and also occasionally with normal 'make check'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d663e47d3a..c6da764618 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,13 +35,13 @@ include $(top_srcdir)/common/release.mak
include $(top_srcdir)/common/po.mak
check-valgrind:
- cd tests/check && make check-valgrind
+ $(MAKE) -C tests/check check-valgrind
if HAVE_GST_CHECK
check-torture:
- cd tests/check && make torture
+ $(MAKE) -C tests/check torture
build-checks:
- cd tests/check && make build-checks
+ $(MAKE) -C tests/check build-checks
else
check-torture:
true