summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-09-02 11:07:49 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-09-02 11:07:49 +0000
commit3846745b4909f3f4bcffc08d17715e0828d79771 (patch)
tree925cfcca960ac88acec3963516da2e6cd9a5e1f8 /Makefile.am
parent1685eb1d31e6eb6a96b06a1f8ed2044a2c78256b (diff)
fix a small bug in the pygst.py install rule; add an uninstall rule
Original commit message from CVS: fix a small bug in the pygst.py install rule; add an uninstall rule
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f305041c1b..bc7934b9bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,10 +27,15 @@ install-data-local: Makefile
sed -e "s|@PYGSTDIR\@|$(PYTHONDIR)/gst-$(GST_MAJORMINOR)|g" \
-e "s|@GST_MAJORMINOR\@|$(GST_MAJORMINOR)|g" \
$(srcdir)/pygst.py.in > $(DESTDIR)$(pythondir)/pygst.py
- chmod 644 $(DESTDIR)$(pyexecdir)/pygst.py
+ chmod 644 $(DESTDIR)$(pythondir)/pygst.py
echo "gst-$(GST_MAJORMINOR)" > $(DESTDIR)$(pythondir)/pygst.pth
# also install pth file in pyexec.
install-exec-local:
$(mkinstalldirs) $(DESTDIR)$(pyexecdir)
echo "gst-$(GST_MAJORMINOR)" > $(DESTDIR)$(pyexecdir)/pygst.pth
+
+uninstall-local:
+ @rm $(DESTDIR)/$(pythondir)/pygst.py > /dev/null 2>&1 || true
+ @rm $(DESTDIR)/$(pythondir)/pygst.pth > /dev/null 2>&1 || true
+ @rm $(DESTDIR)/$(pyexecdir)/pygst.pth > /dev/null 2>&1 || true