summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2003-08-21 04:38:27 +0000
committerDavid Schleef <ds@schleef.org>2003-08-21 04:38:27 +0000
commit0bdeb409207ddef32548eb0e6e9b87fb41fcb969 (patch)
treec04f60d238567646466f6c6b85e7d6333bddbff4 /configure.ac
parent2491e23c46ecd56ab730808b52475ce0d01f274f (diff)
Add --enable-poisoning option, and make it default to off in normal releases, on in ./autogen.sh configuration. Add ...
Original commit message from CVS: Add --enable-poisoning option, and make it default to off in normal releases, on in ./autogen.sh configuration. Add automake17 as a possible automake name.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d755ddc376..d9fc0ba2a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -336,6 +336,16 @@ esac],
[BUILD_EXAMPLES=yes]) dnl Default value
AM_CONDITIONAL(BUILD_EXAMPLES, test "x$BUILD_EXAMPLES" = "xyes")
+dnl poison destroyed objects
+AC_ARG_ENABLE(poisoning,
+AC_HELP_STRING([--enable-poisoning],[enable poisoning of deallocated objects]),
+[case "${enableval}" in
+ yes) USE_POISONING=yes ;;
+ no) USE_POISONING=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-poisoning) ;;
+esac],
+[USE_POISONING=no]) dnl Default value
+
dnl Next, check for the optional components:
dnl ========================================
@@ -394,6 +404,10 @@ if test "x$USE_FAST_STACK_TRASH" = xyes; then
AC_DEFINE(USE_FAST_STACK_TRASH, 1, [Define if we should use i586 optimized stack functions])
fi
+if test "x$USE_POISONING" = xyes; then
+ AC_DEFINE(USE_POISONING, 1, [Define if we should poison deallocated memory])
+fi
+
dnl test if we have pthread_attr_setstack; if not use the older calls
AC_CHECK_LIB(pthread, pthread_attr_setstack,
AC_DEFINE(HAVE_PTHREAD_ATTR_SETSTACK, 1,