summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-01-10 12:43:35 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-01-10 12:43:35 +0000
commitdf28e0bdb6c2e5c3e09ed83bdb7bc7051bbfe27d (patch)
tree109c03e99ebb9447604f5baf21dc9a9175600c1c /configure.ac
parent016c84228c2892f64ca07955f1a900d8e199a1a2 (diff)
autogen.sh: Add -Wno-portability to the automake parameters to stop warnings about GNU make extensions being used. We...
Original commit message from CVS: * autogen.sh: Add -Wno-portability to the automake parameters to stop warnings about GNU make extensions being used. We require GNU make in almost every Makefile anyway. * configure.ac: Use AM_PROG_CC_C_O as a compiler that accepts both -c and -o at the same time is required for per target flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bbdb7971a7..e92499bbbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,9 @@ AC_PROG_CC
AM_PROG_CC_STDC
AS="${CC}"
+dnl check if the compiler supports '-c' and '-o' options
+AM_PROG_CC_C_O
+
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")