summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2016-09-08 12:58:54 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2016-09-13 13:46:19 +0530
commitb6e69ffdfb3bb21dbada8f01b488ae877f8d205c (patch)
treebbd9caccda6ae786bf63741ecf67c99f14855648 /configure.ac
parentc7e0299d2420154513403519a3f8fea59a276028 (diff)
gstconfig: Use __declspec when built with MinGW and linking with MSVC
Earlier we were only using __declspec(dllexport/import) when we were built with MSVC because when built with MinGW and linking with MinGW we don't need it (and we get linker errors because of it). However, when we're built with MinGW and someone wants to link to us with MSVC, we still need the prototypes to have __declspec(dllimport) since MSVC cannot do auto-import like GCC can. https://bugzilla.gnome.org/show_bug.cgi?id=771029
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 71f8280db0..f2def0e8e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,8 +133,8 @@ AG_GST_SET_PACKAGE_RELEASE_DATETIME_WITH_NANO([$PACKAGE_VERSION_NANO],
# We only use this when building with MSVC, which is only done with the
# alternate Meson build system files
-GSTCONFIG_USE_MSVC_DECLSPEC=0
-AC_SUBST(GSTCONFIG_USE_MSVC_DECLSPEC)
+GSTCONFIG_BUILT_WITH_MSVC=0
+AC_SUBST(GSTCONFIG_BUILT_WITH_MSVC)
dnl check for bash completion
AC_ARG_WITH([bash-completion-dir],