summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-08-10 14:00:21 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-08-10 14:01:19 +0100
commit94d2e4c2230be9a8e8be4835da85356c58882732 (patch)
tree5802af372edd2d141946ff87885eefb5f0af2fe2 /meson.build
parent7acdfa3753f317efe3637bd9aab4aebe6a3b65b9 (diff)
meson: hide symbols by default unless explicitly exported
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bccb5f81e9..ffce497eff 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,11 @@ else
noseh_link_args = []
endif
+# Symbol visibility
+if cc.has_argument('-fvisibility=hidden')
+ add_project_arguments('-fvisibility=hidden', language: 'c')
+endif
+
core_conf = configuration_data()
check_headers = [
['HAVE_DLFCN_H', 'dlfcn.h'],