summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-09-24 18:22:26 +0100
committerTim-Philipp Müller <tim@centricular.com>2016-09-24 18:22:26 +0100
commite04d2f230d8a1e505d192915d43bdbfbc76814de (patch)
tree3c0825d00fb3f6bebf3b35f66f2dea5265669b83 /meson.build
parent557e06a6f13076f406890569b1de49419d82c06d (diff)
meson: remove incorrect and unneeded check for ptrdiff_t
Need to include stddef.h for it, so this would've worked: if cc.has_type('ptrdiff_t', prefix: '#include <stddef.h>')
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index f80fd991da..28aeb731ac 100644
--- a/meson.build
+++ b/meson.build
@@ -183,10 +183,6 @@ if cc.has_function('clock_gettime', prefix : '#include <time.h>')
cdata.set('HAVE_CLOCK_GETTIME', 1)
endif
-if cc.has_type('ptrdiff_t')
- cdata.set('HAVE_PTRDIFF_T')
-endif
-
# We only want to use the __declspec(dllexport/import) dance in GST_EXPORT when
# building with MSVC
if cc.get_id() == 'msvc'