summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGreg Manning <gmanning@rapitasystems.com>2023-11-06 18:51:06 +0000
committerAlex Bennée <alex.bennee@linaro.org>2023-11-08 15:15:23 +0000
commit36fa07739450a02a92244a4f0c6973c1df7a9a0c (patch)
tree619a50681c5b871ff11f9181f66fd632dfa5c75b /meson.build
parentf8347d05df3709fd4b62629b2c92b9ad130831f9 (diff)
plugins: allow plugins to be enabled on windows
allow plugins to be enabled in the configure script on windows. Also, add the qemu_plugin_api.lib to the installer. Signed-off-by: Greg Manning <gmanning@rapitasystems.com> Reviewed-by: Alex Bennée <alex.bennee@linaro.org> Message-Id: <20231102172053.17692-5-gmanning@rapitasystems.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org> [AJB: add check for dlltool to configure] Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Message-Id: <20231106185112.2755262-17-alex.bennee@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4848930680..d7d841e71e 100644
--- a/meson.build
+++ b/meson.build
@@ -3944,6 +3944,11 @@ endforeach
if get_option('plugins')
install_headers('include/qemu/qemu-plugin.h')
+ if targetos == 'windows'
+ # On windows, we want to deliver the qemu_plugin_api.lib file in the qemu installer,
+ # so that plugin authors can compile against it.
+ install_data(win32_qemu_plugin_api_lib, install_dir: 'lib')
+ endif
endif
subdir('qga')