summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2023-09-29 11:40:03 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2023-12-31 09:11:28 +0100
commitcfc1a889e509ffeba6e44cca8ff626751bc4219e (patch)
treebe88a62804cdac81dec5e6ad95db70e2286a762c /meson.build
parent0d66549cf5b76bde9870af0d09a46d6d6c306e53 (diff)
meson: rename config_all
config_all now lists only accelerators, rename it to indicate its actual content. Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 6e5a8a5b48..754c469ec9 100644
--- a/meson.build
+++ b/meson.build
@@ -2886,7 +2886,7 @@ endif
minikconf = find_program('scripts/minikconf.py')
-config_all = {}
+config_all_accel = {}
config_all_devices = {}
config_devices_mak_list = []
config_devices_h = {}
@@ -2974,7 +2974,7 @@ foreach target : target_dirs
foreach sym: accelerators
if sym == 'CONFIG_TCG' or target in accelerator_targets.get(sym, [])
config_target += { sym: 'y' }
- config_all += { sym: 'y' }
+ config_all_accel += { sym: 'y' }
if target in modular_tcg
config_target += { 'CONFIG_TCG_MODULAR': 'y' }
else
@@ -4204,18 +4204,18 @@ endif
# Targets and accelerators
summary_info = {}
if have_system
- summary_info += {'KVM support': config_all.has_key('CONFIG_KVM')}
- summary_info += {'HVF support': config_all.has_key('CONFIG_HVF')}
- summary_info += {'WHPX support': config_all.has_key('CONFIG_WHPX')}
- summary_info += {'NVMM support': config_all.has_key('CONFIG_NVMM')}
+ summary_info += {'KVM support': config_all_accel.has_key('CONFIG_KVM')}
+ summary_info += {'HVF support': config_all_accel.has_key('CONFIG_HVF')}
+ summary_info += {'WHPX support': config_all_accel.has_key('CONFIG_WHPX')}
+ summary_info += {'NVMM support': config_all_accel.has_key('CONFIG_NVMM')}
summary_info += {'Xen support': xen.found()}
if xen.found()
summary_info += {'xen ctrl version': xen.version()}
endif
summary_info += {'Xen emulation': config_all_devices.has_key('CONFIG_XEN_EMU')}
endif
-summary_info += {'TCG support': config_all.has_key('CONFIG_TCG')}
-if config_all.has_key('CONFIG_TCG')
+summary_info += {'TCG support': config_all_accel.has_key('CONFIG_TCG')}
+if config_all_accel.has_key('CONFIG_TCG')
if get_option('tcg_interpreter')
summary_info += {'TCG backend': 'TCI (TCG with bytecode interpreter, slow)'}
else