summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2017-02-02 20:50:48 -0800
committerJoe Wilm <jwilm@users.noreply.github.com>2017-02-03 08:11:19 -0800
commitf2f750f9f3688e20d44bf43e6c0f568cf86edaa5 (patch)
tree176fa38cfe17e3b63e0df0dc3f9a14ce0db0d510 /Cargo.toml
parent875167a51006944da1a397fd0131b9aa69bf9a02 (diff)
Alacritty now compiles on stable Rust :tada:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 1 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f7bbb161..fa09a27f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,10 +11,6 @@ doc = false
path = "src/main.rs"
name = "alacritty"
-[[test]]
-name = "ref"
-harness = false
-
[dependencies]
libc = "*"
cgmath = "0.7"
@@ -23,7 +19,7 @@ bitflags = "*"
font = { path = "./font" }
errno = "0.1.6"
lazy_static = "0.2.2"
-parking_lot = { version = "0.3.1", features = ["nightly"] }
+parking_lot = "0.3.1"
serde = "0.9"
serde_yaml = "0.6"
serde_derive = "0.9"
@@ -52,9 +48,6 @@ gl_generator = "0.5"
git = "https://github.com/jwilm/glutin"
rev = "af7fe340bd4a2af53ea521defcb4f377cdc588cf"
-[dev-dependencies]
-rustc-test = { version = "0.1", features = ["capture"] }
-
[profile.release]
lto = true
debug = true