summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKayla Firestack <dev@kaylafire.me>2021-10-18 13:27:51 -0400
committerKayla Firestack <dev@kaylafire.me>2021-10-18 16:30:52 -0400
commit1f8fc31ddc1975a1f2e7c2fa8f7f611eab761680 (patch)
tree62eef03a32544a61c45665e6c4b4ea8014fd6fc8 /flake.nix
parent7e97ef59bd30154776417748b6518ec43a3db2b9 (diff)
split mount into a library crate for rust reuse
update makefile to output shared library and rust build fix default.nix to properly get the binary name for `ln`ing - move binary to main.rs add rustfmt and gitignore files move build.rs file into bch_bindgen for reuse between projects add outputs to nix flake and checks add mount.toml to makefile
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 36dda0ec..02df6c73 100644
--- a/flake.nix
+++ b/flake.nix
@@ -32,15 +32,19 @@
tools
toolsValgrind
toolsDebug
+ mount
+ bch_bindgen
kernel;
- musl-tools = pkgs.pkgsMusl.bcachefs.tools;
- musl-mount = pkgs.pkgsMusl.bcachefs.mount;
+ tools-musl = pkgs.pkgsMusl.bcachefs.tools;
+ mount-musl = pkgs.pkgsMusl.bcachefs.mount;
};
checks = {
kernelSrc = packages.kernel.src;
inherit (packages)
+ mount
+ bch_bindgen
toolsValgrind;
};