summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorEmil Ernerfeldt <emil.ernerfeldt@gmail.com>2022-11-05 11:18:13 +0100
committerGitHub <noreply@github.com>2022-11-05 11:18:13 +0100
commita0b3f1126b158d41db91c3418695f12133bc1329 (patch)
tree514fd75ff8c0f56617eeb3b631807a394b75abaa /Cargo.toml
parent25718f27747218878ca1f62744ad50acbef24457 (diff)
Add helpers for zooming an app using Ctrl+Plus and Ctrl+Minus (#2239)
* Using tracing-subscriber in hello_world example * Add Key::Plus/Minus/Equals * Warn if failing to guess OS from User-Agent * Remove jitter when using Context::set_pixels_per_point * Demo app: zoom in/out using ⌘+ and ⌘- * Demo app: make backend panel GUI scale slider better * Optimize debug builds a bit * typo * Update changelog * Add helper module `egui::gui_zoom` for zooming an app * Better names, and update changelog * Combine Plus and Equals keys * Last fix * Fix docs
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 9 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b8e0adc2..06ee751e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,9 +15,6 @@ members = [
"examples/*",
]
-[profile.dev]
-split-debuginfo = "unpacked" # faster debug builds on mac
-
[profile.release]
# lto = true # VERY slightly smaller wasm
# opt-level = 's' # 10-20% smaller wasm compared to `opt-level = 3`
@@ -26,3 +23,12 @@ opt-level = 2 # fast and small wasm, basically same as `opt-level = 's'`
# opt-level = 3 # unecessarily large wasm for no performance gain
# debug = true # include debug symbols, useful when profiling wasm
+
+
+[profile.dev]
+split-debuginfo = "unpacked" # faster debug builds on mac
+opt-level = 1 # Make debug builds run faster
+
+# Optimize all dependencies even in debug builds (does not affect workspace packages):
+[profile.dev.package."*"]
+opt-level = 2