summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2015-03-23 10:30:33 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2015-03-23 10:30:33 -0700
commit2393085c9ac30ac7378a39ee77760dfdecd4b509 (patch)
tree233f1e457cff8a131c2acf5ba9c947f820e24a5a /configure.ac
parent7f55d4251806e4712762bef0a3ed41a53f850a58 (diff)
parentad89f85067d068494009948e76f89c902f043513 (diff)
Merge from origin/emacs-24
ad89f85 Another minor improvement in ELisp manual (Bug#20168) 5e2951b Improve docs of 'posn-actual-col-row' (Bug#20169) 1291ce1 Minor documentation fix in ELisp manual (Bug#20174) 33e2236 * display.texi (Useless Whitespace): Fix thinko. ff3878d * configure.ac: Fix jpeg version check to work with gcc >= 5. 90b46f5 Work for the case nnmail-expiry-target is an nnmh group (bug#20170) e7f92aa authors.el small additions 0bfe915 * etc/PROBLEMS: Add entry about dir-locals and some auto-mounters. c3c4b75 Fixes: debbugs:18939 Conflicts: ChangeLog doc/lispref/ChangeLog etc/PROBLEMS lisp/ChangeLog lisp/gnus/ChangeLog lisp/simple.el
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 40c8d2b93a8..bed94fbaa20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3197,10 +3197,12 @@ if test "${opsys}" = "mingw32"; then
AH_TEMPLATE(HAVE_JPEG, [Define to 1 if you have the jpeg library (-ljpeg).])dnl
if test "${HAVE_JPEG}" = "yes"; then
AC_DEFINE(HAVE_JPEG)
- AC_EGREP_CPP([version= *(6[2-9]|[7-9][0-9])],
- [#include <jpeglib.h>
- version=JPEG_LIB_VERSION
-],
+ AC_EGREP_CPP([version 6b or later],
+ [#include <jpeglib.h>
+ #if JPEG_LIB_VERSION >= 62
+ version 6b or later
+ #endif
+ ],
[AC_DEFINE(HAVE_JPEG)],
[AC_MSG_WARN([libjpeg found, but not version 6b or later])
HAVE_JPEG=no])
@@ -3216,10 +3218,12 @@ elif test "${HAVE_X11}" = "yes" || test "${HAVE_W32}" = "yes"; then
AH_TEMPLATE(HAVE_JPEG, [Define to 1 if you have the jpeg library (-ljpeg).])dnl
if test "${HAVE_JPEG}" = "yes"; then
AC_DEFINE(HAVE_JPEG)
- AC_EGREP_CPP([version= *(6[2-9]|[7-9][0-9])],
+ AC_EGREP_CPP([version 6b or later],
[#include <jpeglib.h>
- version=JPEG_LIB_VERSION
-],
+ #if JPEG_LIB_VERSION >= 62
+ version 6b or later
+ #endif
+ ],
[AC_DEFINE(HAVE_JPEG)],
[AC_MSG_WARN([libjpeg found, but not version 6b or later])
HAVE_JPEG=no])