summaryrefslogtreecommitdiff
path: root/gio/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gio/meson.build')
-rw-r--r--gio/meson.build14
1 files changed, 13 insertions, 1 deletions
diff --git a/gio/meson.build b/gio/meson.build
index 8f897d5fa..b17ab8148 100644
--- a/gio/meson.build
+++ b/gio/meson.build
@@ -526,6 +526,7 @@ gio_sources = files(
'gioscheduler.c',
'giostream.c',
'gloadableicon.c',
+ 'gmarshal-internal.c',
'gmount.c',
'gmemoryinputstream.c',
'gmemoryoutputstream.c',
@@ -1003,4 +1004,15 @@ subdir('fam')
build_tests = not meson.is_cross_build() or (meson.is_cross_build() and meson.has_exe_wrapper())
if build_tests
subdir('tests')
-endif \ No newline at end of file
+endif
+
+# The following is an example for building internal marshallers that are used
+# by GIO. We cannot guarantee glib-genmarshal availability while building GLib
+# so they are pre-generated and placed into gmarshal-internal.[ch].
+#
+# gmarshal_internal = gnome.genmarshal('gmarshal-internal',
+# sources: 'gmarshal-internal.list',
+# prefix: '_g_cclosure_marshal',
+# valist_marshallers: true,
+# internal: true,
+# )