summaryrefslogtreecommitdiff
path: root/gio/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gio/tests/Makefile.am')
-rw-r--r--gio/tests/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/gio/tests/Makefile.am b/gio/tests/Makefile.am
index caab30912..8fcdd9cb7 100644
--- a/gio/tests/Makefile.am
+++ b/gio/tests/Makefile.am
@@ -54,6 +54,9 @@ TEST_PROGS += \
gdbus-error \
gdbus-peer \
gdbus-exit-on-close \
+ application \
+ testapps \
+ appinfo \
$(NULL)
endif
@@ -73,6 +76,8 @@ SAMPLE_PROGS = \
gdbus-example-subtree \
gdbus-example-peer \
gdbus-example-proxy-subclass \
+ testapp \
+ appinfo-test \
$(NULL)
@@ -248,6 +253,21 @@ gdbus_example_proxy_subclass_LDADD = $(progs_ldadd)
gdbus_example_export_SOURCES = gdbus-example-export.c
gdbus_example_export_LDADD = $(progs_ldadd)
+application_SOURCES = application.c
+application_LDADD = $(progs_ldadd)
+
+appinfo_SOURCES = appinfo.c
+appinfo_LDADD = $(progs_ldadd)
+
+appinfo_test_SOURCES = appinfo-test.c
+appinfo_test_LDADD = $(progs_ldadd)
+
+testapp_SOURCES = testapp.c
+testapp_LDADD = $(progs_ldadd)
+
+testapps_SOURCES = testapps.c
+testapps_LDADD = $(progs_ldadd)
+
EXTRA_DIST += \
socket-common.c \
org.gtk.test.gschema \