summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2012-11-28 18:50:45 +0100
committerEdward Hervey <bilboed@bilboed.com>2012-11-28 18:50:45 +0100
commit8edd1443a8c1615676c05722004575f7759157a6 (patch)
tree69dea56df0a936a1404e50864198dba998abc6fa /configure.ac
parentb511f938d414749f0ebd577b3eaa965e5ca1f3fd (diff)
configure.ac: Update libtool versioning
In order for 1.x and 1.(x+1) versions to not invade on each other we need to have different lib versions. So we need a consistent and predictable scheme: library version number = MINOR * 100 + MICRO Ex: 1.0.0 => 0 (duh) 1.0.3 => 3 1.1.0 => 100 1.1.1 => 101 1.2.0 => 120 1.10.5 => 1005
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d71c0c3986..1eed0af95b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,8 +47,16 @@ dnl - library source changed -> increment REVISION
dnl - interfaces added/removed/changed -> increment CURRENT, REVISION = 0
dnl - interfaces added -> increment AGE
dnl - interfaces removed -> AGE = 0
+dnl
+dnl Keep CURRENT as MINOR * 100 + MICRO
+dnl Ex : 1.0.0 => 0
+dnl 1.0.3 => 3
+dnl 1.1.0 => 100
+dnl 1.2.5 => 205
+dnl 1.10.9 (who knows) => 1009
+dnl
dnl sets GST_LT_LDFLAGS
-AS_LIBTOOL(GST, 2, 0, 2)
+AS_LIBTOOL(GST, 100, 0, 100)
dnl *** required versions of GStreamer stuff ***
GST_REQ=1.1.0