summaryrefslogtreecommitdiff
path: root/ext/ffmpeg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/ffmpeg/Makefile.am')
-rw-r--r--ext/ffmpeg/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/ext/ffmpeg/Makefile.am b/ext/ffmpeg/Makefile.am
index d746d8e366..3490e352b0 100644
--- a/ext/ffmpeg/Makefile.am
+++ b/ext/ffmpeg/Makefile.am
@@ -7,17 +7,16 @@ libgstffmpeg_la_SOURCES = gstffmpeg.c \
# gstffmpegdemux.c \
# gstffmpegmux.c \
# gstffmpegprotocol.c \
-# gstffmpegcolorspace.c \
# gstffmpegscale.c \
# gstffmpegdeinterlace.c
-libgstffmpeg_la_CFLAGS = $(GST_CFLAGS) \
+libgstffmpeg_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) \
-I $(top_srcdir)/gst-libs/ext/ffmpeg/libavformat \
-I $(top_srcdir)/gst-libs/ext/ffmpeg/libavutil \
-I $(top_srcdir)/gst-libs/ext/ffmpeg/libavcodec
libgstffmpeg_la_LIBADD = \
- $(top_builddir)/gst-libs/ext/ffmpeg/libavformat/libavformat.la
-
+ $(top_builddir)/gst-libs/ext/ffmpeg/libavformat/libavformat.la \
+ $(GST_LIBS)
libgstffmpeg_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \