summaryrefslogtreecommitdiff
path: root/subprojects/gst-plugins-bad/ext/openjpeg/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/gst-plugins-bad/ext/openjpeg/meson.build')
-rw-r--r--subprojects/gst-plugins-bad/ext/openjpeg/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/subprojects/gst-plugins-bad/ext/openjpeg/meson.build b/subprojects/gst-plugins-bad/ext/openjpeg/meson.build
new file mode 100644
index 0000000000..822f2c94ff
--- /dev/null
+++ b/subprojects/gst-plugins-bad/ext/openjpeg/meson.build
@@ -0,0 +1,30 @@
+openjpeg_sources = [
+ 'gstopenjpeg.c',
+ 'gstopenjpegdec.c',
+ 'gstopenjpegenc.c',
+]
+
+openjpeg_cargs = []
+
+if get_option('openjpeg').disabled()
+ subdir_done()
+endif
+
+openjpeg_dep = dependency('libopenjp2', version : '>=2.2',
+ fallback : ['libopenjp2', 'libopenjp2_dep'],
+ required : get_option('openjpeg'))
+
+if openjpeg_dep.found()
+ gstopenjpeg = library('gstopenjpeg',
+ openjpeg_sources,
+ c_args : gst_plugins_bad_args + openjpeg_cargs,
+ link_args : noseh_link_args,
+ include_directories : [configinc],
+ dependencies : [gst_dep, gstvideo_dep, openjpeg_dep,
+ gstcodecparsers_dep, libm],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+ pkgconfig.generate(gstopenjpeg, install_dir : plugins_pkgconfig_install_dir)
+ plugins += [gstopenjpeg]
+endif