summaryrefslogtreecommitdiff
path: root/subprojects/gst-plugins-bad/gst/rtmp2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/gst-plugins-bad/gst/rtmp2/meson.build')
-rw-r--r--subprojects/gst-plugins-bad/gst/rtmp2/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/subprojects/gst-plugins-bad/gst/rtmp2/meson.build b/subprojects/gst-plugins-bad/gst/rtmp2/meson.build
new file mode 100644
index 0000000000..e9cabbd647
--- /dev/null
+++ b/subprojects/gst-plugins-bad/gst/rtmp2/meson.build
@@ -0,0 +1,25 @@
+rtmp2_sources = [
+ 'gstrtmp2.c',
+ 'gstrtmp2element.c',
+ 'gstrtmp2locationhandler.c',
+ 'gstrtmp2sink.c',
+ 'gstrtmp2src.c',
+ 'rtmp/amf.c',
+ 'rtmp/rtmpchunkstream.c',
+ 'rtmp/rtmpclient.c',
+ 'rtmp/rtmpconnection.c',
+ 'rtmp/rtmphandshake.c',
+ 'rtmp/rtmpmessage.c',
+ 'rtmp/rtmputils.c',
+]
+
+gstrtmp2 = library('gstrtmp2',
+ rtmp2_sources,
+ c_args : gst_plugins_bad_args,
+ include_directories : [configinc, libsinc],
+ dependencies : [gstbase_dep, gio_dep, libm],
+ install : true,
+ install_dir : plugins_install_dir,
+)
+pkgconfig.generate(gstrtmp2, install_dir : plugins_pkgconfig_install_dir)
+plugins += [gstrtmp2]