summaryrefslogtreecommitdiff
path: root/crates/smtp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/smtp/Cargo.toml')
-rw-r--r--crates/smtp/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/crates/smtp/Cargo.toml b/crates/smtp/Cargo.toml
index b4c0f0af..630a38ad 100644
--- a/crates/smtp/Cargo.toml
+++ b/crates/smtp/Cargo.toml
@@ -7,7 +7,7 @@ homepage = "https://stalw.art/smtp"
keywords = ["smtp", "email", "mail", "server"]
categories = ["email"]
license = "AGPL-3.0-only OR LicenseRef-SEL"
-version = "0.8.3"
+version = "0.8.4"
edition = "2021"
resolver = "2"
@@ -18,17 +18,17 @@ nlp = { path = "../nlp" }
directory = { path = "../directory" }
common = { path = "../common" }
mail-auth = { version = "0.4" }
-mail-send = { version = "0.4", default-features = false, features = ["cram-md5"] }
+mail-send = { version = "0.4", default-features = false, features = ["cram-md5", "ring", "tls12"] }
mail-parser = { version = "0.9", features = ["full_encoding", "ludicrous_mode"] }
mail-builder = { version = "0.3", features = ["ludicrous_mode"] }
smtp-proto = { version = "0.1", features = ["serde_support"] }
sieve-rs = { version = "0.5" }
ahash = { version = "0.8" }
-rustls = "0.22"
+rustls = { version = "0.23.5", default-features = false, features = ["std", "ring", "tls12"] }
rustls-pemfile = "2.0"
rustls-pki-types = { version = "1" }
tokio = { version = "1.23", features = ["full"] }
-tokio-rustls = { version = "0.25.0"}
+tokio-rustls = { version = "0.26", default-features = false, features = ["ring", "tls12"] }
webpki-roots = { version = "0.26"}
hyper = { version = "1.0.1", features = ["server", "http1", "http2"] }
hyper-util = { version = "0.1.1", features = ["tokio"] }