summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1f64d1e1..e48120e8 100644
--- a/meson.build
+++ b/meson.build
@@ -122,6 +122,10 @@ else
error('unhandled crypto value @0@'.format(want_crypto))
endif
+libseccomp = dependency('libseccomp',
+ static : get_option('buildstatic'),
+ required : false)
+conf.set('HAVE_LIBSECCOMP', libseccomp.found())
foreach header : [
'linux/landlock.h',
'mntent.h',
@@ -327,7 +331,7 @@ libcommon = static_library(
gnu_symbol_visibility : 'hidden',
install : false)
-alpm_deps = [crypto_provider, libarchive, libcurl, libintl, gpgme]
+alpm_deps = [crypto_provider, libarchive, libcurl, libintl, libseccomp, gpgme]
libalpm_a = static_library(
'alpm_objlib',