summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChet Ramey <chet.ramey@case.edu>2024-04-22 10:41:37 -0400
committerChet Ramey <chet.ramey@case.edu>2024-04-22 10:41:37 -0400
commit69e5c5e4c9778bf86c3d1c6b058ddece70854de8 (patch)
tree47180ebc4b0b8218364c19b4f185de971387329c /configure.ac
parent5d4d92f221d6aac4be445bdd8cd9b48d9ac33f04 (diff)
Readline-8.3-alpha releasereadline-8.3-alpha
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 15501fa..4604750 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@ dnl report bugs to chet@po.cwru.edu
dnl
dnl Process this file with autoconf to produce a configure script.
-# Copyright (C) 1987-2022 Free Software Foundation, Inc.
+# Copyright (C) 1987-2024 Free Software Foundation, Inc.
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -20,9 +20,9 @@ dnl Process this file with autoconf to produce a configure script.
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-AC_REVISION([for Readline 8.2, version 2.97])
+AC_REVISION([for Readline 8.3, version 2.98])
-AC_INIT(readline, 8.2, bug-readline@gnu.org)
+AC_INIT(readline, 8.3, bug-readline@gnu.org)
dnl make sure we are using a recent autoconf version
AC_PREREQ(2.69)
@@ -32,7 +32,7 @@ AC_CONFIG_AUX_DIR(./support)
AC_CONFIG_HEADERS(config.h)
dnl update the value of RL_READLINE_VERSION in readline.h when this changes
-LIBVERSION=8.2
+LIBVERSION=8.3
AC_CANONICAL_HOST
AC_CANONICAL_BUILD
@@ -118,7 +118,8 @@ AC_USE_SYSTEM_EXTENSIONS
# If we're using gcc and the user hasn't specified CFLAGS, add -O2 to CFLAGS
if test -n "$want_auto_cflags" ; then
AUTO_CFLAGS="-g ${GCC:+-O2}"
- STYLE_CFLAGS="${GCC:+-Wno-parentheses} ${GCC:+-Wno-format-security} ${GCC:+-Wno-tautological-constant-out-of-range-compare}"
+# STYLE_CFLAGS="${GCC:+-Wno-parentheses} ${GCC:+-Wno-format-security} ${GCC:+-Wno-tautological-constant-out-of-range-compare}"
+ STYLE_CFLAGS="${GCC:+-Wno-parentheses} ${GCC:+-Wno-format-security}"
fi
AC_PROG_GCC_TRADITIONAL