summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2a5d733..bbbb2eb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,9 +1,9 @@
[package]
name = "rocksdb"
description = "Rust wrapper for Facebook's RocksDB embeddable database"
-version = "0.21.0"
+version = "0.22.0"
edition = "2018"
-rust-version = "1.66.0"
+rust-version = "1.70.0"
authors = ["Tyler Neely <t@jujit.su>", "David Greenberg <dsg123456789@gmail.com>"]
repository = "https://github.com/rust-rocksdb/rust-rocksdb"
license = "Apache-2.0"
@@ -25,6 +25,7 @@ default = ["snappy", "lz4", "zstd", "zlib", "bzip2"]
jemalloc = ["librocksdb-sys/jemalloc"]
io-uring = ["librocksdb-sys/io-uring"]
valgrind = []
+mt_static = ["librocksdb-sys/mt_static"]
snappy = ["librocksdb-sys/snappy"]
lz4 = ["librocksdb-sys/lz4"]
zstd = ["librocksdb-sys/zstd"]
@@ -36,11 +37,11 @@ serde1 = ["serde"]
[dependencies]
libc = "0.2"
-librocksdb-sys = { path = "librocksdb-sys", version = "0.15.0" }
+librocksdb-sys = { path = "librocksdb-sys", version = "0.17.0" }
serde = { version = "1", features = [ "derive" ], optional = true }
[dev-dependencies]
-trybuild = "1.0"
+trybuild = "<=1.0.89" # trybuild 1.0.90 needs MSRV 1.70
tempfile = "3.1"
pretty_assertions = "1.0"
bincode = "1.3"